Uploaded image for project: 'JikesRVM'
  1. JikesRVM
  2. RVM-139

Update environment on regression machines

    Details

    • Type: Task
    • Status: Closed
    • Priority: Medium
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Infrastructure
    • Labels:
      None

      Description

      Can we update the regression machines so that they all have ruby and rake (a ruby build tool) present and also if possible update ant to 1.7.0.

      I would like to start experimenting and eventually move to rake as the mechanism for running and maintaining our tests. Ant is broken in so many ways and our build files are becoming very painful to maintain. Looking at jikesrvm.anu.edu.au it looks like the bundled packages are rake 0.7.1 and ruby 1.8.5 - both of which are modern enough for what we need to do.

      Ant 1.7.0 has many features that would be "nice to have" but the only feature that is really of significant interest is the apt task which simplifies running apt over many many files and may recompile during that time (which would make RVM-39 Open much easier).

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              pdonald Peter Donald
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: