Uploaded image for project: 'JikesRVM'
  1. JikesRVM
  2. RVM-325

Spec JVM 98 jack failing with OOMs

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Medium
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.0
    • Component/s: Infrastructure: Test
    • Labels:
      None

      Description

      I'm not sure if this is more common since r13833 but we're now quite regularly failing Spec JVM 98 Jack with OOMs:

      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/perf/1653/production/default/perf-jvm98/jack-3GC/2/Output.txt

        Gliffy Diagrams

          Attachments

            Activity

            ianrogers Ian Rogers added a comment -

            I'm bumping the priority of this, it's now a consistent failure with a tight heap since the upgrade to Classpath 0.97 (possibly related to extra space requirements of StringBuffers?). Here's another example:
            http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/perf/3023/production/default/perf-jvm98/jack-3GC/5/Output.txt

            ianrogers Ian Rogers added a comment -

            Small heap size bumped from 17MB to 18MB in r14166 in an attempt to resolve this.

            ianrogers Ian Rogers added a comment -

            Pushing to 2.9.4 as change to test configuration should have already closed this issue.

            ianrogers Ian Rogers added a comment -

            Bumping heap sizes fixed this - its not shown in regression reports for a long while.

            dgrove David Grove added a comment -

            reopening so I can modify fix target to 3.0


              People

              • Assignee:
                ianrogers Ian Rogers
                Reporter:
                ianrogers Ian Rogers
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: