Uploaded image for project: 'JikesRVM'
  1. JikesRVM
  2. RVM-514

Pure on mathMagic breaks dacapo sunflow

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Medium
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.0
    • Component/s: Compiler: Optimizing
    • Labels:
      None

      Description

      The change in commit 14036 (specifically to the single parameter version of mathMagic) causes dacapo sunflow (from the dacapo head) to reliably fail with an image validation check (I assume some floating point error has crept in).

      This may be related to the intermittent lusearch problem.

        Gliffy Diagrams

          Attachments

            Activity

            dgrove David Grove created issue -
            steveblackburn Steve Blackburn added a comment -

            Further info:

            Sunflow worked on March 13 [1], r14029 [2] but has been broken since March 14 [3] , r14037 [4]. The stack trace is here [5].

            I understand that Sunflow works in our current head if you simply disable the pure annotation (Daniel?).

            [1] http://jikesrvm.anu.edu.au/~dacapo/regression/results-20080313/
            [2] http://jikesrvm.anu.edu.au/~dacapo/regression/results-20080313/jikesrvm.build.log
            [3] http://jikesrvm.anu.edu.au/~dacapo/regression/results-20080314/
            [4] http://jikesrvm.anu.edu.au/~dacapo/regression/results-20080314/jikesrvm.build.log
            [5] http://jikesrvm.anu.edu.au/~dacapo/regression/results-20080314/JIKESRVM/sunflow.default.tmp.log

            steveblackburn Steve Blackburn added a comment -

            The meta point here is that I am trying to move forward with the next DaCapo release, and as a background task, trying to see if we can fix Jikes RVM bugs exposed by the dacapo head.

            zyridium Daniel Frampton added a comment -

            As Steve mentioned I investigated the change in more detail and narrowed it down to just un-@Pure-ing that mathMagic method.

            ianrogers Ian Rogers added a comment -

            With Daniel's help I've confirmed there's a bug in LocalCSE, we transform:

            y = tan x
            z = sin x

            into

            y = tan x
            z = y

            this is because the local CSE is only comparing arguments and not the method or address parameters.

            ianrogers Ian Rogers added a comment -

            Patch committed in r14323.

            dgrove David Grove added a comment -

            reopening so I can modify fix target to 3.0

            dgrove David Grove made changes -
            Field Original Value New Value
            Workflow jira [ 17199 ] X10 Workflow [ 18393 ]
            dgrove David Grove made changes -
            Priority Major [ 6 ] Medium [ 3 ]

              People

              • Assignee:
                ianrogers Ian Rogers
                Reporter:
                zyridium Daniel Frampton
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: