Uploaded image for project: 'JikesRVM'
  1. JikesRVM
  2. RVM-545

java.lang.instrument support for Harmony

    Details

    • Type: New Feature
    • Status: Resolved
    • Priority: Medium
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
      None

      Description

      We currently don't support java.lang.instrument for apache Harmony. This causes the TestResolveOnCheckcast, TestResolveOnInstanceof and TestAgent basic tests to fail.

        Gliffy Diagrams

          Attachments

            Activity

            dgrove David Grove created issue -
            dgrove David Grove added a comment -

            bulk defer open issues to 3.1.2

            dgrove David Grove added a comment -

            defer to 3.1.4

            ebrangs Erik Brangs added a comment -

            We're no longer committed to Apache Harmony because it's dead upstream. This makes most of the Apache Harmony issues uninteresting. The issues RVM-925 and RVM-849 are exceptions because they could be caused by bugs in the Jikes RVM.

            dgrove David Grove added a comment -

            Closing all harmony issues as won't fix

            dgrove David Grove made changes -
            Field Original Value New Value
            Workflow jira [ 17628 ] X10 Workflow [ 18862 ]
            dgrove David Grove made changes -
            Priority Major [ 6 ] Medium [ 3 ]

              People

              • Assignee:
                Unassigned
                Reporter:
                ianrogers Ian Rogers
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: