Uploaded image for project: 'JikesRVM'
  1. JikesRVM
  2. RVM-99

MeasureCompilation reporting broken in production/development builds on ia32-linux

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Lowest
    • Resolution: Fixed
    • Affects Version/s: 2.9.1
    • Fix Version/s: 2.9.2
    • Component/s: Compiler: Optimizing
    • Labels:
      None

      Description

      Running with -X:vm:measureComplilation=true on a production, development, production_Opt_0 or production_Opt_1 image on ia32-linux results in an apparent infinite loop while printing the report if no methods were opt compiled. The initial section of the report is printed ok, but it gets stuck while trying to print out the opt compiler details.

      To reproduce, it should be sufficient to build on of the problem images and do:

      rvm -X:vm:measureCompilation=true -X:aos:enable_recompilation=false

      If at least one method is opt compiled; then the report is generated just fine and the VM exits normally.

        Gliffy Diagrams

          Attachments

            Activity

            mikebond Michael Bond added a comment -

            Fixed in r13617.

            A loop prints spaces before total compilation time (for right justification); if the time is zero, it's an infinite loop. Made minor change to handle zero. By the way, reproducing the bug in the trunk required both -X:vm:measureCompilation=true and -X:vm:measureCompilationPhases=true; I guess the second command-line option is new?

            (I chose "Resolve Issue." Was this the right thing to do, or was "Close Issue" the right thing? Please let me know if there's anything else I should have done differently since this is my first commit

            dgrove David Grove added a comment -

            closing as 2.9.2 is imminent.


              People

              • Assignee:
                mikebond Michael Bond
                Reporter:
                dgrove David Grove
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: